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Guide to shoreline segmentation in 
buffers using QGIS 

1. BACKGROUND 

Within the framework of the CleanAtlantic project, numerical modelling has been used for the research and 

monitoring of sea litter areas and in particular macroplastics. 

In this context, INTECMAR, in collaboration with the rest of the partners, has concentrated on the local 

scale, the size of an estuary (few tens of kilometers).  

The objective of the use of numerical modeling in INTECMAR is twofold: 1) to develop the methodology to 

find the areas of greatest accumulation on the coast of estuaries; 2) relate the accumulation zones to the 

different ocean-weather situations. 

The following is a summary of the model implementation as an introduction: 

The geographical area considered is the Ria da Arousa, the largest of the Galician Rias and the largest 

seafood production. Inside it has several large islands, including the Illa de Arousa and the Island of Sálvora 

that have been studied in this project. 

The model has been run for an entire year, from October 2018 to October 2019. The Lagrangian model 

discharges the same amount of particles into the ria every 3 hours. The particles that reach the ground are 

fixed at that point of coast. The model records the timing and position of this beaching. 

Once the entire year of moments and positions of particles on the coast has been obtained, INTECMAR has 

developed some methodologies for the study of them. One of them is based on the segmentation of the 

coast into sections of equal size. The study would group, for example, the amount of particles that have 

beached in each of the sections for each day, thus obtaining a time series of accumulation of 24 hours for 

each stretch of coast. From here, different accumulation maps can be made, such as the one shown in the 

following figure, which is the maximum level of particles accumulated in 24 hours over a year. 



 

Fig. 1 Segments represented the maximum accumulation in 24 hours over a year. 

This guide will explain how to create these sections or segments from the shoreline. 

2. PREPARATION OF THE PROJECT 

The QGIS program (https://qgis.org/) will be used to perform this task. QGIS is a professional open-source 

GIS application under GNU – General Public License. The GRASS Toolbox (https://grass.osgeo.org) will be 

used in automatic segmentation. This software is already integrated into QGIS. For the use of both 

packages, it is recommended to install QGIS via OSGeo4W (https://www.osgeo.org/projects/osgeo4w/) if 

using Windows. OSGEO4W consists of a Windows installer of the main GIS open-source packages. 

The goal of this guide is to obtain a GIS file that contains the sections where the particles will be counted. It 

should be noted that each section is actually a polygon, consisting of a piece of coastline and a certain 

thickness, which is where the particle is considered to have beached. A later program will count all particles 

contained in that polygon. 

It is therefore necessary to start from a file with a coastline. In this case the coastline provided by the 

Hydrographic Institute of the Spanish Navy (http://ideihm.covam.es) has been used, from where it can be 

downloaded in shapefile format from its WFS service. 

The coastline to be used as an example is a cut in Spain's coastline for the Ria de Arousa. Cleaning up some 

sections containing marshes or bridges, the line to be used is as follows: 



 

Fig. 2 Initial coastline (in green). It has overlapned a base layer to illustrate the base layer's situation. 

2.1. Project preparation 

1) Create a new project in QGIS. 

2) Chose as coordinate reference system (CRS), WGS84, EPSG:4326. To do this, open Project > Properties 

> SRC and choose WGS84, EPSG:4326 

3) Add the shoreline layer and save. 

Note that from now on the WGS84 CRS will be used which means that the native units are decimal degrees. 

You could use other types of CRS and even units, but it is convenient to stay in these so as not to avoid 

problems with projections. Therefore, any reference where units of distance in meters are needed, it is 

advisable to convert them to decimal degrees and use the latter units. 

3. CREATING SEGMENTS MANUALLY 

La creación de segmentos de forma manual consiste en el recorte de un polígono del ancho deseado que 

recorre la línea de costa en diversas partes de forma manual. Normalmente estos tramos se corresponden 

a áreas significativas donde se quieren obtener los acúmulos, como pueden ser las playas de una 

determinada zona. 

3.1. Creating the shoreline outer edge (buffer) 

For the process it is preferable to convert the coastline into a polygon. This will be done by creating a 

closed coastline and then converting it to polygon. 



• Create a copy of the coastline in our project: Choose the layer and right-click Export>Save Objects 

As... Choose ESRI Shape File format,a name and the sameprojection: 

 

• Edit the new created layer and with the vertex tool add the required points until you create a closed 

line. Save: 

 

• Convert the closed shoreline to a polygon: To do this, choose Vector > Geometry Tools > Lines to 

Polygons: 



 

• Buffer Creation: We Choose Vector > Geoprocessing Tools > Buffer... 

 



 

A menu is displayed, where you choose the layer you want to buffer, the buffer distance (you have 

chosen 0.0009 degrees which is approximately 100 m for these latitudes) and the file where you want 

to record the result. 

 

The result is a polygon whose border protrudes the indicated distance. Remember that units are 

geographic degrees. 



• Removing the Protruding Edge: Vector > Geoprocessing Tool > Difference... 

A menu is displayed where the input layer is chosen, which is the result of the buffer process and the 

overlay layer, which in this case is the polygon of the shoreline. 

 

It runs and the result is the outer edge of the buffer: 

 

This layer is the one to be manipulated manually so it is recommended to export a copy, choosing the 

layer in the Layers Panel and choosing the Export...  option with a right-click. 



 

3.2. Selecting the area to segment 

The creation of segments manually is typically used because they correspond to specific parts of the 

coastline. As an example, a layer will be created with the segments corresponding to the beaches of the Illa 

de Arousa in which garbage sampling was made.  

1) The first action is to remove from the layer with which to work all polygons that are not of our interest. 

To do this, select the target area with the Select tool from the toolbar. 



 

Once selected, we reverse the selection, to select the leftover part 

 

The Edit tool is activated. 



 

It is removed with the Delete tool and saved: 

 

2) Final polygon cleanup: There may be some areas where it is interesting that a single polygon exists, 

such as overlapping ones: 



 

Selecting all polygons and using advanced editing tools, you choose Merge Selected Spatial Objects 

and select Merge and OK from the menu. 

 

The result is a single polygon. The layer is saved and deactivate the edit mode. 

 



 

3.3. Split the polygon into segments 

Once a single border has been obtained it is time to split it into segments as desired. In this example, 

sampling beaches on Arousa Island will be used as a guide. To do this, this layer is included in the project. 

 



1) To split the border in polygons, the"Split Features with Steroids" plugin will be used. To do this, you 

need to add it in the Plugins section. 

2) After the plugin is added, activate the outer edge layer in edit mode and the polygon is selected so that 

you can modify it. From now on the polygon will be split into chunks using the beach layer as a guide.  

 

3) You select the Split Features with Steroids tool on the toolbar and split the polygon by drawing lines 

using the left button to add vertex and the right button to finish. 

 



4) Repeating the process with the different beaches should get the desired result. Everything is saved and 

deactivate edit mode. The layer is finished and ready to use. 

 

  



4. CREATING SEGMENTS AUTOMATICALLY 

Segment creation is automatically used to segment the coast into consecutive sections of the same size. 

Note that in this context, segment refers to a polygon that follows the coastline with a single width and a 

normally larger length. 

QGIS will be used with GRASS tools in this process. Therefore, when opening the project you will choose the 

program "QGISx.x.x with GRASS". 

4.1. Simplification of the coast 

Because, in this case, the creation of polygons is done automatically, it is necessary to simplify the coast, so 

that undesirable artifacts do not occur at those points where it is highly trimmed. The simplification process 

will take place in two phases: first the coast will be discretized and then softened 

1) Open QGIS with GRASS 

2) Open the project created in section 2 

3) Open the GRASS Toolbox: Processes > Toolbox > GRASS 

4) Shore Discretization: Choose the v.generalizetool. A menu is displayed where the following parameters 

are chosen: 

a) Input layer: The layer to be simplified 

b) Algorithm: Douglas 

c) Tolerance: The higher the tolerance, the greater the steps. Keep in mind that units are degrees, so 

a good value for these latitudes is 0.0005 

d) Advanced parameters. Generalized: If left blank, the result is saved to a temporary layer, which will 

be cleared when the project is closed. In this case, you have chosen to save it to a permanent layer. 

 

The result is the brown line in the following figure: 



 

1) Smoothing the coast: This is again chosen in the GRASS Toolbox: Processes > Toolbox > GRASS  the  

v.generalize tool. 

2) The menu is displayed and the following parameters are chosen: 

a) Input layer: The layer resulting from the previous discretization process 

b) Algorithm: Chaiken 

c) Maximum tolerance value: The higher the overallization. The value chosen for this case was 0.0001 

d) Advanced parameters. Generalized: Permanent output layer. 

 

 



 

The result is a simplified coastline. By changing the tolerance parameters, you can get the desired 

result: 

 



 

4.2. Divide the coast into segments (lines) 

This section will divide the simplification coastline into line segments of equal size. Note that these 

segments are not the desired end segments, as the latter are polygons of a given width. 

1) Join all coastlines into a single feature: 

a) Select the resulting layer from the previous process and open Edit mode.  

b) Select all lines. 

c) In the Advanced Scan tools, choose Combine Spatial Objects.  

d) In the menu choose Combine,  OK. 

e) Save the layer and exit edit mode. 



 
2) Coast Division: Choose in the GRASS Toolbox: Processes > Toolbox > GRASS>v.split  tool. 

3) In the menu choose: 

a) Input line layer: The resulting layer from the previous process. 

b) Maximum segment length: Segment size to degrees. For this latitude (42oN), 0.00892 has been 

chosen which is approximately 1000 m 

c) Length units: map. 

d) Force given length: Mark. 

e) Divide by Length: Resulting layer. It is important in this case to choose a non-permanent output 

layer. 

 

 

 

 

 

 

 



 

4) Differentiate Records: The resulting layer is the simplified coastline divided into segments. To verify 

that this is the case, you can open your attribute table. Because all features come from a single 

polygon, all of their records are the same. It is desirable that at least one field has different values. 

a) In the Attribute Table, enter edit mode. 

b) In the top bar choose a field (example: cat) and match it to @row_number 

c) Click Update All 

d) Save and exit edit mode 

 

5) By changing the symbology to a color ramp by categories, you can see the result obtained: 



 

4.3. Creating segments (polygons) 

Buffers with the desired width will be created to move from line segments to polygons. 

1) Choose Vector>Buffer Geoprocessing Tools... 

2) In the menu choose the following parameters: 

a) Input layer: The resulting layer from the previous project 

b) Distance: Desired width, in degrees. In this case 0.0009 has been chosen. About 100 m for latitude 

42º. 

c) Completion Style: Plane 

d) Buffered: Output layer 



 

 

The result is the desired final layer, with the coast segmented into polygons of equal size except where it is 

not possible: 

 



You may want to correct some automatically spurious artifacts. To do this, edit the layer and use the 

Advanced Digitalization and Digitalization tool bars. 

5. FILES 

This guide attaches a compressed file named BufferGuideline.zip containing the projects in QGIS and the 

layers used in this guide. 

6. CONTACT INFORMATION 

for additional information you can contact us through the following ways:  

• Email: udac@intecmar.gal 

• Phone: 986512320 Extensions 236/208 

• Web: www.intecmar.gal;  www.cleanatlantic.eu 

 

mailto:udac@intecmar.gal
http://www.intecmar.gal/
http://www.cleanatlantic.eu/
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